CVE-2017-2604GHSA-M93H-5QMX-PPHG
In Jenkins before versions 2.44, 2.32.2 low privilege users were able to act on administrative monitors due to them not being consistently p
- Published
- Last modified
- Where the record stands: published, rejected by its publisher, or superseded by another id.What do these mean? →
- published
- Whether CISA lists it in its Known Exploited Vulnerabilities catalog: proof that attackers are using it.What do these mean? →
- Not listed in CISA KEV
- Fix
- Fixed in 2.32.2, 2.44
- Whether working attack code is public (Exploit-DB, Metasploit, Nuclei or GitHub). Public code makes attacks easier.What do these mean? →
- None on Exploit-DB, Metasploit or GitHub
Summary
In Jenkins before versions 2.44, 2.32.2 low privilege users were able to act on administrative monitors due to them not being consistently protected by permission checks (SECURITY-371).
Timeline
- CVE published
- Record last updated
Affected versions
- [UNKNOWN] jenkins
jenkins 2.44, jenkins 2.32.2
- org.jenkins-ci.main:jenkins-coreMaven
fixed in 2.32.2
- org.jenkins-ci.main:jenkins-coreMaven
From 2.34 · fixed in 2.44