Skip to main content
← All vulnerabilities
CVE-2017-2600GHSA-WJ5C-J656-H5FW

In jenkins before versions 2.44, 2.32.2 node monitor data could be viewed by low privilege users via the remote API.

Published
Last modified
published
Not listed in CISA KEV
Fix
Fixed in 2.32.2, 2.44
None on Exploit-DB, Metasploit or GitHub

Summary

In jenkins before versions 2.44, 2.32.2 node monitor data could be viewed by low privilege users via the remote API. These included system configuration and runtime information of these nodes (SECURITY-343).

Timeline

  1. CVE published
  2. Record last updated

Affected versions

  • [UNKNOWN] jenkins

    jenkins 2.44, jenkins 2.32.2

  • org.jenkins-ci.main:jenkins-coreMaven

    fixed in 2.32.2

  • org.jenkins-ci.main:jenkins-coreMaven

    From 2.34 · fixed in 2.44

References 4

jenkins.io

securityfocus.com

bugzilla.redhat.com

GitHub · jenkinsci/jenkins