Skip to main content
← All vulnerabilities
CVE-2017-2599GHSA-7R4H-2H23-6JQ9

Jenkins before versions 2.44 and 2.32.2 is vulnerable to an insufficient permission check.

Published
Last modified
published
Not listed in CISA KEV
Fix
Fixed in 2.32.2, 2.44
None on Exploit-DB, Metasploit or GitHub

Summary

Jenkins before versions 2.44 and 2.32.2 is vulnerable to an insufficient permission check. This allows users with permissions to create new items (e.g. jobs) to overwrite existing items they don't have access to (SECURITY-321).

Timeline

  1. CVE published
  2. Record last updated

Affected versions

  • [UNKNOWN] jenkins

    jenkins 2.44, jenkins 2.32.2

  • org.jenkins-ci.main:jenkins-coreMaven

    fixed in 2.32.2

  • org.jenkins-ci.main:jenkins-coreMaven

    From 2.34 · fixed in 2.44

References 4

securityfocus.com

jenkins.io

bugzilla.redhat.com

GitHub · jenkinsci/jenkins