CVE-2017-2592GHSA-XCP8-HH74-F6MCPYSEC-2018-104
python-oslo-middleware before versions 3.8.1, 3.19.1, 3.23.1 is vulnerable to an information disclosure.
- Published
- Last modified
- Where the record stands: published, rejected by its publisher, or superseded by another id.What do these mean? →
- published
- Whether CISA lists it in its Known Exploited Vulnerabilities catalog: proof that attackers are using it.What do these mean? →
- Not listed in CISA KEV
- Fix
- Fixed in 3.19.1, 3.8.1, 3.23.1
- Whether working attack code is public (Exploit-DB, Metasploit, Nuclei or GitHub). Public code makes attacks easier.What do these mean? →
- None on Exploit-DB, Metasploit or GitHub
Summary
python-oslo-middleware before versions 3.8.1, 3.19.1, 3.23.1 is vulnerable to an information disclosure. Software using the CatchError class could include sensitive values in a traceback's error message. System users could exploit this flaw to obtain sensitive information from OpenStack component error logs (for example, keystone tokens).
Timeline
- CVE published
- Record last updated
Affected versions
- unspecified python-oslo-middleware
python-oslo-middleware 3.8.1, python-oslo-middleware 3.19.1, python-oslo-middleware 3.23.1
- oslo-middlewarePyPI
From 3.9.0 · fixed in 3.19.1
- oslo-middlewarePyPI
fixed in 3.8.1
- oslo-middlewarePyPI
From 3.20.0 · fixed in 3.23.1
- oslo-middlewarePyPI
From 3.9.0 · fixed in 3.19.1; fixed in 3.8.1; From 3.20.0 · fixed in 3.23.1