Skip to main content
← All vulnerabilities
CVE-2017-2096GHSA-F489-655R-X6GR

smalruby-editor v0.4.0 and earlier allows remote attackers to execute arbitrary OS commands via unspecified vectors.

Published
Last modified
published
Not listed in CISA KEV
Fix
Fixed in 0.4.1, 0.1.11
None on Exploit-DB, Metasploit or GitHub

Summary

smalruby-editor v0.4.0 and earlier allows remote attackers to execute arbitrary OS commands via unspecified vectors.

Timeline

  1. CVE published
  2. Record last updated

Affected versions

  • Ruby Programming Shounendan smalruby-editor

    Version range not reported

  • smalruby-editorRubyGems

    fixed in 0.4.1

  • smalrubyRubyGems

    fixed in 0.1.11

References 3

jvn.jp

securityfocus.com

smalruby.jp