CVE-2017-18917GHSA-JXC4-W54C-QV5RGO-2026-4463
An issue was discovered in Mattermost Server before 3.8.2, 3.7.5, and 3.6.7.
- Published
- Last modified
- Where the record stands: published, rejected by its publisher, or superseded by another id.What do these mean? →
- published
- Whether CISA lists it in its Known Exploited Vulnerabilities catalog: proof that attackers are using it.What do these mean? →
- Not listed in CISA KEV
- Fix
- Fixed in 3.7.5-0.20170421192444-247cd1e51a8c, 3.8.2, 3.8.2+incompatible
- Whether working attack code is public (Exploit-DB, Metasploit, Nuclei or GitHub). Public code makes attacks easier.What do these mean? →
- None on Exploit-DB, Metasploit or GitHub
Summary
An issue was discovered in Mattermost Server before 3.8.2, 3.7.5, and 3.6.7. Weak hashing was used for e-mail invitations, OAuth, and e-mail verification tokens.
Timeline
- CVE published
- Record last updated
Affected versions
- n/a n/a
Version range not reported
- github.com/mattermost/mattermost-serverGo
fixed in 3.7.5-0.20170421192444-247cd1e51a8c
- github.com/mattermost/mattermost-serverGo
From 3.8.0 · fixed in 3.8.2
- github.com/mattermost/mattermost-serverGo
From 3.8.0+incompatible · fixed in 3.8.2+incompatible