CVE-2017-18916GO-2026-4467GHSA-X33G-375J-JHF7
An issue was discovered in Mattermost Server before 3.8.2, 3.7.5, and 3.6.7.
- Published
- Last modified
- Where the record stands: published, rejected by its publisher, or superseded by another id.What do these mean? →
- published
- Whether CISA lists it in its Known Exploited Vulnerabilities catalog: proof that attackers are using it.What do these mean? →
- Not listed in CISA KEV
- Fix
- Fixed in 3.7.5+incompatible, 3.8.2+incompatible, 3.6.7-0.20170420152529-0968e4079e0a, 3.7.5, 3.8.2
- Whether working attack code is public (Exploit-DB, Metasploit, Nuclei or GitHub). Public code makes attacks easier.What do these mean? →
- None on Exploit-DB, Metasploit or GitHub
Summary
An issue was discovered in Mattermost Server before 3.8.2, 3.7.5, and 3.6.7. API endpoint access control does not honor an integration permission restriction.
Timeline
- CVE published
- Record last updated
Affected versions
- n/a n/a
Version range not reported
- github.com/mattermost/mattermost-serverGo
From 3.7.0+incompatible · fixed in 3.7.5+incompatible; From 3.8.0+incompatible · fixed in 3.8.2+incompatible
- github.com/mattermost/mattermost-serverGo
fixed in 3.6.7-0.20170420152529-0968e4079e0a
- github.com/mattermost/mattermost-serverGo
From 3.7.0 · fixed in 3.7.5
- github.com/mattermost/mattermost-serverGo
From 3.8.0 · fixed in 3.8.2