Skip to main content
← All vulnerabilities
CVE-2017-18915GHSA-HXXJ-8PHW-74VWGO-2026-4462

An issue was discovered in Mattermost Server before 3.8.2, 3.7.5, and 3.6.7.

Published
Last modified
published
Not listed in CISA KEV
Fix
Fixed in 3.6.7-0.20170420152529-0968e4079e0a, 3.7.5, 3.8.2, 3.7.5+incompatible, 3.8.2+incompatible
None on Exploit-DB, Metasploit or GitHub

Summary

An issue was discovered in Mattermost Server before 3.8.2, 3.7.5, and 3.6.7. After a restart of a server, an attacker might suddenly gain API Endpoint access.

Timeline

  1. CVE published
  2. Record last updated

Affected versions

  • n/a n/a

    Version range not reported

  • github.com/mattermost/mattermost-serverGo

    fixed in 3.6.7-0.20170420152529-0968e4079e0a

  • github.com/mattermost/mattermost-serverGo

    From 3.7.0 · fixed in 3.7.5

  • github.com/mattermost/mattermost-serverGo

    From 3.8.0 · fixed in 3.8.2

  • github.com/mattermost/mattermost-serverGo

    From 3.7.0+incompatible · fixed in 3.7.5+incompatible; From 3.8.0+incompatible · fixed in 3.8.2+incompatible

References 1

mattermost.com