CVE-2017-18911GHSA-M462-MQW4-2C8MGO-2026-4464
An issue was discovered in Mattermost Server before 3.8.2, 3.7.5, and 3.6.7.
- Published
- Last modified
- Where the record stands: published, rejected by its publisher, or superseded by another id.What do these mean? →
- published
- Whether CISA lists it in its Known Exploited Vulnerabilities catalog: proof that attackers are using it.What do these mean? →
- Not listed in CISA KEV
- Fix
- Fixed in 3.6.7-rc1, 3.7.5, 3.8.2, 3.6.7-rc1+incompatible, 3.7.5+incompatible, and 1 more
- Whether working attack code is public (Exploit-DB, Metasploit, Nuclei or GitHub). Public code makes attacks easier.What do these mean? →
- None on Exploit-DB, Metasploit or GitHub
Summary
An issue was discovered in Mattermost Server before 3.8.2, 3.7.5, and 3.6.7. The X.509 certificate validation can be skipped for a TLS-based e-mail server.
Timeline
- CVE published
- Record last updated
Affected versions
- n/a n/a
Version range not reported
- github.com/mattermost/mattermost-serverGo
fixed in 3.6.7-rc1
- github.com/mattermost/mattermost-serverGo
From 3.7.0 · fixed in 3.7.5
- github.com/mattermost/mattermost-serverGo
From 3.8.0 · fixed in 3.8.2
- github.com/mattermost/mattermost-serverGo
fixed in 3.6.7-rc1+incompatible; From 3.7.0+incompatible · fixed in 3.7.5+incompatible; From 3.8.0+incompatible · fixed in 3.8.2+incompatible