Skip to main content
← All vulnerabilities
CVE-2017-18906GO-2026-4477GHSA-FPCR-4RR5-HPCP

An issue was discovered in Mattermost Server before 4.0.0, 3.10.2, and 3.9.2, when Single Sign-On OAuth2 is used.

Published
Last modified
published
Not listed in CISA KEV
Fix
Fixed in 3.10.2+incompatible, 3.9.2-0.20170714134023-b17fca0d5ee7, 3.10.2
None on Exploit-DB, Metasploit or GitHub

Summary

An issue was discovered in Mattermost Server before 4.0.0, 3.10.2, and 3.9.2, when Single Sign-On OAuth2 is used. An attacker could claim somebody else's account.

Timeline

  1. CVE published
  2. Record last updated

Affected versions

  • n/a n/a

    Version range not reported

  • github.com/mattermost/mattermost-serverGo

    From 3.10.0+incompatible · fixed in 3.10.2+incompatible

  • github.com/mattermost/mattermost-serverGo

    fixed in 3.9.2-0.20170714134023-b17fca0d5ee7

  • github.com/mattermost/mattermost-serverGo

    From 3.10.0 · fixed in 3.10.2

References 1

mattermost.com