Skip to main content
← All vulnerabilities
CVE-2017-18904GO-2026-4302GHSA-8PFF-P3GX-W4JF

An issue was discovered in Mattermost Server before 4.0.0, 3.10.2, and 3.9.2.

Published
Last modified
published
Not listed in CISA KEV
Fix
Fixed in 3.9.2+incompatible, 3.10.2+incompatible, 3.9.2, 3.10.2
None on Exploit-DB, Metasploit or GitHub

Summary

An issue was discovered in Mattermost Server before 4.0.0, 3.10.2, and 3.9.2. It allows XSS via an uploaded file.

Timeline

  1. CVE published
  2. Record last updated

Affected versions

  • n/a n/a

    Version range not reported

  • github.com/mattermost/mattermost-serverGo

    fixed in 3.9.2+incompatible; From 3.10.0+incompatible · fixed in 3.10.2+incompatible

  • github.com/mattermost/mattermost-serverGo

    fixed in 3.9.2

  • github.com/mattermost/mattermost-serverGo

    From 3.10.0 · fixed in 3.10.2

References 1

mattermost.com