Skip to main content
← All vulnerabilities
CVE-2017-18894GO-2026-4297GHSA-GG42-MWR6-P82C

An issue was discovered in Mattermost Server before 4.2.0, 4.1.1, and 4.0.5, when used as an OAuth 2.0 service provider.

Published
Last modified
published
Not listed in CISA KEV
Fix
Fixed in 4.0.5+incompatible, 4.1.1+incompatible, 4.2.0+incompatible, 4.0.5, 4.1.1, and 1 more
None on Exploit-DB, Metasploit or GitHub

Summary

An issue was discovered in Mattermost Server before 4.2.0, 4.1.1, and 4.0.5, when used as an OAuth 2.0 service provider. Sometimes. resource-owner authorization is bypassed, allowing account takeover.

Timeline

  1. CVE published
  2. Record last updated

Affected versions

  • n/a n/a

    Version range not reported

  • github.com/mattermost/mattermost-serverGo

    fixed in 4.0.5+incompatible; From 4.1.0+incompatible · fixed in 4.1.1+incompatible; From 4.2.0-rc1+incompatible · fixed in 4.2.0+incompatible

  • github.com/mattermost/mattermost-serverGo

    fixed in 4.0.5

  • github.com/mattermost/mattermost-serverGo

    From 4.1.0 · fixed in 4.1.1

  • github.com/mattermost/mattermost-serverGo

    From 4.2.0-rc1 · fixed in 4.2.0

References 1

mattermost.com