Skip to main content
← All vulnerabilities
CVE-2017-18884GHSA-876J-JFQF-M7J7GO-2025-4197

An issue was discovered in Mattermost Server before 4.3.0, 4.2.1, and 4.1.2.

Published
Last modified
published
Not listed in CISA KEV
Fix
Fixed in 4.1.2, 4.2.1, 4.3.0, 4.1.2+incompatible, 4.2.1+incompatible, and 1 more
None on Exploit-DB, Metasploit or GitHub

Summary

An issue was discovered in Mattermost Server before 4.3.0, 4.2.1, and 4.1.2. It allows attackers to gain privileges by using a registered OAuth application with personal access tokens.

Timeline

  1. CVE published
  2. Record last updated

Affected versions

  • n/a n/a

    Version range not reported

  • github.com/mattermost/mattermost-serverGo

    fixed in 4.1.2

  • github.com/mattermost/mattermost-serverGo

    From 4.2.0-rc1 · fixed in 4.2.1

  • github.com/mattermost/mattermost-serverGo

    From 4.3.0-rc1 · fixed in 4.3.0

  • github.com/mattermost/mattermost-serverGo

    fixed in 4.1.2+incompatible; From 4.2.0-rc1+incompatible · fixed in 4.2.1+incompatible; From 4.3.0-rc1+incompatible · fixed in 4.3.0+incompatible

References 1

mattermost.com