Skip to main content
← All vulnerabilities
CVE-2017-18878GO-2025-4191GHSA-H564-6GC2-FCC6

An issue was discovered in Mattermost Server before 4.3.0, 4.2.1, and 4.1.2.

Published
Last modified
published
Not listed in CISA KEV
Fix
Fixed in 4.3.0+incompatible, 4.1.2-0.20171004201910-6be8113eb60c, 4.2.1-0.20171004192657-8fbbd688ea24, 4.3.0
None on Exploit-DB, Metasploit or GitHub

Summary

An issue was discovered in Mattermost Server before 4.3.0, 4.2.1, and 4.1.2. Knowledge of a session ID allows revoking another user's session.

Timeline

  1. CVE published
  2. Record last updated

Affected versions

  • n/a n/a

    Version range not reported

  • github.com/mattermost/mattermost-serverGo

    From 4.3.0-rc1+incompatible · fixed in 4.3.0+incompatible

  • github.com/mattermost/mattermost-serverGo

    fixed in 4.1.2-0.20171004201910-6be8113eb60c

  • github.com/mattermost/mattermost-serverGo

    From 4.2.0-rc1 · fixed in 4.2.1-0.20171004192657-8fbbd688ea24

  • github.com/mattermost/mattermost-serverGo

    From 4.3.0-rc1 · fixed in 4.3.0

References 1

mattermost.com