CVE-2017-18877GHSA-9X8X-W6G5-HX4WGO-2025-4190
An issue was discovered in Mattermost Server before 4.3.0, 4.2.1, and 4.1.2.
- Published
- Last modified
- Where the record stands: published, rejected by its publisher, or superseded by another id.What do these mean? →
- published
- Whether CISA lists it in its Known Exploited Vulnerabilities catalog: proof that attackers are using it.What do these mean? →
- Not listed in CISA KEV
- Fix
- Fixed in 4.1.2, 4.2.1, 4.3.0, 4.1.2+incompatible, 4.2.1+incompatible, and 1 more
- Whether working attack code is public (Exploit-DB, Metasploit, Nuclei or GitHub). Public code makes attacks easier.What do these mean? →
- None on Exploit-DB, Metasploit or GitHub
Summary
An issue was discovered in Mattermost Server before 4.3.0, 4.2.1, and 4.1.2. XSS attacks could occur against an OAuth 2.0 allow/deny page.
Timeline
- CVE published
- Record last updated
Affected versions
- n/a n/a
Version range not reported
- github.com/mattermost/mattermost-serverGo
fixed in 4.1.2
- github.com/mattermost/mattermost-serverGo
From 4.2.0 · fixed in 4.2.1
- github.com/mattermost/mattermost-serverGo
From 4.3.0-rc1 · fixed in 4.3.0
- github.com/mattermost/mattermost-serverGo
fixed in 4.1.2+incompatible; From 4.2.0+incompatible · fixed in 4.2.1+incompatible; From 4.3.0-rc1+incompatible · fixed in 4.3.0+incompatible