CVE-2017-18873GHSA-X6MW-HF2J-VQPCGO-2026-4282
An issue was discovered in Mattermost Server before 4.3.0, 4.2.1, and 4.1.2.
- Published
- Last modified
- Where the record stands: published, rejected by its publisher, or superseded by another id.What do these mean? →
- published
- Whether CISA lists it in its Known Exploited Vulnerabilities catalog: proof that attackers are using it.What do these mean? →
- Not listed in CISA KEV
- Fix
- Fixed in 4.1.2-0.20171013141717-ee57a5829ab1, 4.2.1-0.20171013140502-b3e4b0ac9168, 4.3.0, 4.1.2-0.20171013141717-ee57a5829ab1+incompatible, 4.2.1-0.20171013140502-b3e4b0ac9168+incompatible, and 1 more
- Whether working attack code is public (Exploit-DB, Metasploit, Nuclei or GitHub). Public code makes attacks easier.What do these mean? →
- None on Exploit-DB, Metasploit or GitHub
Summary
An issue was discovered in Mattermost Server before 4.3.0, 4.2.1, and 4.1.2. It allows attackers to cause a denial of service (channel invisibility) via a misformatted post.
Timeline
- CVE published
- Record last updated
Affected versions
- n/a n/a
Version range not reported
- github.com/mattermost/mattermost-serverGo
fixed in 4.1.2-0.20171013141717-ee57a5829ab1
- github.com/mattermost/mattermost-serverGo
From 4.2.0 · fixed in 4.2.1-0.20171013140502-b3e4b0ac9168
- github.com/mattermost/mattermost-serverGo
From 4.3.0-rc1 · fixed in 4.3.0
- github.com/mattermost/mattermost-serverGo
fixed in 4.1.2-0.20171013141717-ee57a5829ab1+incompatible; From 4.2.0+incompatible · fixed in 4.2.1-0.20171013140502-b3e4b0ac9168+incompatible; From 4.3.0-rc1+incompatible · fixed in 4.3.0+incompatible