CVE-2017-18872GO-2025-4075GHSA-HGRP-FGM8-56G8
An issue was discovered in Mattermost Server before 4.4.3 and 4.3.3.
- Published
- Last modified
- Where the record stands: published, rejected by its publisher, or superseded by another id.What do these mean? →
- published
- Whether CISA lists it in its Known Exploited Vulnerabilities catalog: proof that attackers are using it.What do these mean? →
- Not listed in CISA KEV
- Fix
- Fixed in 4.3.3+incompatible, 4.4.3+incompatible, 4.3.3, 4.4.3
- Whether working attack code is public (Exploit-DB, Metasploit, Nuclei or GitHub). Public code makes attacks easier.What do these mean? →
- None on Exploit-DB, Metasploit or GitHub
Summary
An issue was discovered in Mattermost Server before 4.4.3 and 4.3.3. Attackers could reconfigure an OAuth app in some cases where Mattermost is an OAuth 2.0 service provider.
Timeline
- CVE published
- Record last updated
Affected versions
- n/a n/a
Version range not reported
- github.com/mattermost/mattermost-serverGo
fixed in 4.3.3+incompatible; From 4.4.0-rc1+incompatible · fixed in 4.4.3+incompatible
- github.com/mattermost/mattermost-serverGo
fixed in 4.3.3
- github.com/mattermost/mattermost-serverGo
From 4.4.0-rc1 · fixed in 4.4.3