CVE-2017-18871GHSA-JC6W-8R7F-VMP5GO-2025-4184
An issue was discovered in Mattermost Server before 4.5.0, 4.4.5, 4.3.4, and 4.2.2.
- Published
- Last modified
- Where the record stands: published, rejected by its publisher, or superseded by another id.What do these mean? →
- published
- Whether CISA lists it in its Known Exploited Vulnerabilities catalog: proof that attackers are using it.What do these mean? →
- Not listed in CISA KEV
- Fix
- Fixed in 4.2.2, 4.3.4, 4.4.5, 4.5.0, 4.2.2+incompatible, and 3 more
- Whether working attack code is public (Exploit-DB, Metasploit, Nuclei or GitHub). Public code makes attacks easier.What do these mean? →
- None on Exploit-DB, Metasploit or GitHub
Summary
An issue was discovered in Mattermost Server before 4.5.0, 4.4.5, 4.3.4, and 4.2.2. It allows attackers to cause a denial of service (application crash) via an @ character before a JavaScript field name.
Timeline
- CVE published
- Record last updated
Affected versions
- n/a n/a
Version range not reported
- github.com/mattermost/mattermost-serverGo
fixed in 4.2.2
- github.com/mattermost/mattermost-serverGo
From 4.3.0-rc1 · fixed in 4.3.4
- github.com/mattermost/mattermost-serverGo
From 4.4.0-rc1 · fixed in 4.4.5
- github.com/mattermost/mattermost-serverGo
From 4.5.0-rc1 · fixed in 4.5.0
- github.com/mattermost/mattermost-serverGo
fixed in 4.2.2+incompatible; From 4.3.0-rc1+incompatible · fixed in 4.3.4+incompatible; From 4.4.0-rc1+incompatible · fixed in 4.4.5+incompatible; From 4.5.0-rc1+incompatible · fixed in 4.5.0+incompatible