CVE-2017-18587GHSA-Q89X-F52W-6HJ2RUSTSEC-2017-0002
An issue was discovered in the hyper crate before 0.9.18 for Rust.
- Published
- Last modified
- Where the record stands: published, rejected by its publisher, or superseded by another id.What do these mean? →
- published
- Whether CISA lists it in its Known Exploited Vulnerabilities catalog: proof that attackers are using it.What do these mean? →
- Not listed in CISA KEV
- Fix
- Fixed in 0.10.2, 0.9.18
- Whether working attack code is public (Exploit-DB, Metasploit, Nuclei or GitHub). Public code makes attacks easier.What do these mean? →
- None on Exploit-DB, Metasploit or GitHub
Summary
An issue was discovered in the hyper crate before 0.9.18 for Rust. It mishandles newlines in headers.
Timeline
- CVE published
- Record last updated
Affected versions
- n/a n/a
Version range not reported
- hypercrates.io
From 0.10.0 · fixed in 0.10.2
- hypercrates.io
fixed in 0.9.18
- hypercrates.io
From 0.0.0-0 · fixed in 0.9.18; From 0.10.0 · fixed in 0.10.2