Skip to main content
← All vulnerabilities
CVE-2017-16807GHSA-275C-V3RC-XGHX

A cross-site Scripting (XSS) vulnerability in Kirby Panel before 2.3.3, 2.4.x before 2.4.2, and 2.5.x before 2.5.7 exists when displaying a

Published
Last modified
published
Not listed in CISA KEV
Fix
Fixed in 2.3.3, 2.4.2, 2.5.7
1 on Exploit-DB

Summary

A cross-site Scripting (XSS) vulnerability in Kirby Panel before 2.3.3, 2.4.x before 2.4.2, and 2.5.x before 2.5.7 exists when displaying a specially prepared SVG document that has been uploaded as a content file.

Timeline

  1. Public exploit on Exploit-DB

    EDB-43140

  2. CVE published
  3. Record last updated

Affected versions

  • n/a n/a

    Version range not reported

  • getkirby/cmsPackagist

    fixed in 2.3.3

  • getkirby/cmsPackagist

    From 2.4 · fixed in 2.4.2

  • getkirby/cmsPackagist

    From 2.5 · fixed in 2.5.7

References 4

packetstormsecurity.com

getkirby.com

Exploit-DB