Skip to main content
← All vulnerabilities
CVE-2017-16653GHSA-92X6-H2GR-8GXQ

An issue was discovered in Symfony before 2.7.38, 2.8.31, 3.2.14, 3.3.13, 3.4-BETA5, and 4.0-BETA5.

Published
Last modified
published
Not listed in CISA KEV
Fix
Fixed in 2.7.38, 2.8.31, 3.2.14, 3.3.13
None on Exploit-DB, Metasploit or GitHub

Summary

An issue was discovered in Symfony before 2.7.38, 2.8.31, 3.2.14, 3.3.13, 3.4-BETA5, and 4.0-BETA5. The current implementation of CSRF protection in Symfony (Version >=2) does not use different tokens for HTTP and HTTPS; therefore the token is subject to MITM attacks on HTTP and can then be used in an HTTPS context to do CSRF attacks.

Timeline

  1. CVE published
  2. Record last updated

Affected versions

  • n/a n/a

    Version range not reported

  • symfony/security-csrfPackagist

    From 2.7.0 · fixed in 2.7.38

  • symfony/security-csrfPackagist

    From 2.8.0 · fixed in 2.8.31

  • symfony/security-csrfPackagist

    From 3.0.0 · fixed in 3.2.14

  • symfony/security-csrfPackagist

    From 3.3.0 · fixed in 3.3.13

  • symfony/securityPackagist

    From 2.7.0 · fixed in 2.7.38

  • symfony/securityPackagist

    From 2.8.0 · fixed in 2.8.31

  • symfony/securityPackagist

    From 3.0.0 · fixed in 3.2.14

  • symfony/securityPackagist

    From 3.3.0 · fixed in 3.3.13

  • symfony/symfonyPackagist

    From 2.7.0 · fixed in 2.7.38

  • symfony/symfonyPackagist

    From 2.8.0 · fixed in 2.8.31

  • symfony/symfonyPackagist

    From 3.0.0 · fixed in 3.2.14

  • symfony/symfonyPackagist

    From 3.3.0 · fixed in 3.3.13

References 3

symfony.com

GitHub · symfony/symfony

debian.org