Skip to main content
← All vulnerabilities
CVE-2017-16138GHSA-WRVR-8MPX-R7PP

The mime module < 1.4.1, 2.0.1, 2.0.2 is vulnerable to regular expression denial of service when a mime lookup is performed on untrusted use

Published
Last modified
published
Not listed in CISA KEV
Fix
Fixed in 2.0.3, 1.4.1
None on Exploit-DB, Metasploit or GitHub
  • Exploitation: none
  • Automatable: yes
  • Technical impact: partial

Summary

The mime module < 1.4.1, 2.0.1, 2.0.2 is vulnerable to regular expression denial of service when a mime lookup is performed on untrusted user input.

Timeline

  1. CVE published
  2. CISA SSVC assessment

    Exploitation: none · Automatable: yes · Technical impact: partial

  3. Record last updated

Affected versions

  • HackerOne mime node module

    < 1.4.1 || > 2.0.0 < 2.0.3

  • mimenpm

    From 2.0.0 · fixed in 2.0.3

  • mimenpm

    fixed in 1.4.1

References 2

GitHub · broofa/node-mime

nodesecurity.io