CVE-2017-16136GHSA-QX2F-477C-35RQ
method-override is a module used by the Express.js framework to let you use HTTP verbs such as PUT or DELETE in places where the client does
- Published
- Last modified
- Where the record stands: published, rejected by its publisher, or superseded by another id.What do these mean? →
- published
- Whether CISA lists it in its Known Exploited Vulnerabilities catalog: proof that attackers are using it.What do these mean? →
- Not listed in CISA KEV
- Fix
- Fixed in 2.3.10
- Whether working attack code is public (Exploit-DB, Metasploit, Nuclei or GitHub). Public code makes attacks easier.What do these mean? →
- None on Exploit-DB, Metasploit or GitHub
Summary
method-override is a module used by the Express.js framework to let you use HTTP verbs such as PUT or DELETE in places where the client doesn't support it. method-override is vulnerable to a regular expression denial of service vulnerability when specially crafted input is passed in to be parsed via the X-HTTP-Method-Override header.
Timeline
- CVE published
- Record last updated
Affected versions
- HackerOne method-override node module
<= 1.0.2 || > 2.0.0 < 2.3.10
- method-overridenpm
From 1.0.2 · fixed in 2.3.10
- method-overridenpm
From 2.0.0 · fixed in 2.3.10