Skip to main content
← All vulnerabilities
CVE-2017-16010GHSA-CMH5-QC8W-XVCQ

i18next is a language translation framework.

Published
Last modified
published
Not listed in CISA KEV
Fix
Fixed in 3.4.4
None on Exploit-DB, Metasploit or GitHub

Summary

i18next is a language translation framework. When using the .init method, passing interpolation options without passing an escapeValue will default to undefined rather than the assumed true. This can result in a cross-site scripting vulnerability because user input is assumed to be escaped, but is not. This vulnerability affects i18next 2.0.0 and later.

Timeline

  1. CVE published
  2. Record last updated

Affected versions

  • HackerOne i18next node module

    >=2.0.0 <=3.4.3

  • i18nextnpm

    From 2.0.0 · fixed in 3.4.4

References 2

GitHub · i18next/i18next

nodesecurity.io