Skip to main content
← All vulnerabilities
CVE-2017-15719GHSA-PWPC-HQQ2-HX2X

In Wicket jQuery UI 6.28.0 and earlier, 7.9.1 and earlier, and 8.0.0-M8 and earlier, a security issue has been discovered in the WYSIWYG edi

Published
Last modified
published
Not listed in CISA KEV
Fix
Fixed in 6.28.1, 7.9.2, 8.0.0-M8.1
None on Exploit-DB, Metasploit or GitHub

Summary

In Wicket jQuery UI 6.28.0 and earlier, 7.9.1 and earlier, and 8.0.0-M8 and earlier, a security issue has been discovered in the WYSIWYG editor that allows an attacker to submit arbitrary JS code to WYSIWYG editor.

Timeline

  1. CVE published
  2. Record last updated

Affected versions

  • Apache Software Foundation Wicket jQuery UI

    through 6.28.0; through 7.9.1; through 8.0.0-M8

  • com.googlecode.wicket-jquery-ui:wicket-jquery-ui-parentMaven

    fixed in 6.28.1

  • com.googlecode.wicket-jquery-ui:wicket-jquery-ui-parentMaven

    From 7.0.0 · fixed in 7.9.2

  • com.googlecode.wicket-jquery-ui:wicket-jquery-ui-parentMaven

    From 8.0.0-M1 · fixed in 8.0.0-M8.1

References 2

GitHub · sebfz1/wicket-jquery-ui

openmeetings.apache.org