Skip to main content
← All vulnerabilities
CVE-2017-15713GHSA-3V44-382Q-55F4

Vulnerability in Apache Hadoop 0.23.x, 2.x before 2.7.5, 2.8.x before 2.8.3, and 3.0.0-alpha through 3.0.0-beta1 allows a cluster user to ex

Published
Last modified
published
Not listed in CISA KEV
Fix
Fixed in 2.7.5, 2.8.3
None on Exploit-DB, Metasploit or GitHub

Summary

Vulnerability in Apache Hadoop 0.23.x, 2.x before 2.7.5, 2.8.x before 2.8.3, and 3.0.0-alpha through 3.0.0-beta1 allows a cluster user to expose private files owned by the user running the MapReduce job history server process. The malicious user can construct a configuration file containing XML directives that reference sensitive files on the MapReduce job history server host.

Timeline

  1. CVE published
  2. Record last updated

Affected versions

  • Apache Software Foundation Apache Hadoop

    0.23.0 to 0.23.11, 2.0.0-alpha to 2.8.2, 3.0.0-alpha to 3.0.0-beta1

  • org.apache.hadoop:hadoop-mainMaven

    fixed in 2.7.5

  • org.apache.hadoop:hadoop-mainMaven

    From 2.8.0 · fixed in 2.8.3

References 1

lists.apache.org