Skip to main content
← All vulnerabilities
CVE-2017-15708GHSA-P694-23Q3-RVRC

In Apache Synapse, by default no authentication is required for Java Remote Method Invocation (RMI).

Published
Last modified
published
Not listed in CISA KEV
Fix
Fixed in 3.0.1
1 proof of concept on GitHub

Summary

In Apache Synapse, by default no authentication is required for Java Remote Method Invocation (RMI). So Apache Synapse 3.0.1 or all previous releases (3.0.0, 2.1.0, 2.0.0, 1.2, 1.1.2, 1.1.1) allows remote code execution attacks that can be performed by injecting specially crafted serialized objects. And the presence of Apache Commons Collections 3.2.1 (commons-collections-3.2.1.jar) or previous versions in Synapse distribution makes this exploitable. To mitigate the issue, we need to limit RMI access to trusted users only. Further upgrading to 3.0.1 version will eliminate the risk of having said Commons Collection version. In Synapse 3.0.1, Commons Collection has been updated to 3.2.2 version.

Timeline

  1. CVE published
  2. Record last updated
  3. EPSS reached 10%

    FIRST estimates at least a 10% chance of exploitation in the next 30 days

Affected versions

  • Apache Software Foundation Apache Synapse

    3.0.0, 2.1.0, 2.0.0, 1.2, 1.1.2, 1.1.1

  • org.apache.synapse:synapse-coreMaven

    fixed in 3.0.1

References 7

securityfocus.com

lists.apache.org

oracle.com

security.gentoo.org

GitHub · HuSoul/CVE-2017-15708